请选择 进入手机版 | 继续访问电脑版
爱气象,爱气象家园! 

气象家园

 找回密码
 立即注册

QQ登录

只需一步,快速开始

新浪微博登陆

只需一步, 快速开始

搜索
查看: 1582|回复: 6

请教一个WPS安装后的问题:util.src文件夹里没有plotgrids.exe和plotfmt.exe?

[复制链接]

新浪微博达人勋

发表于 2017-8-25 20:01:14 | 显示全部楼层 |阅读模式

登录后查看更多精彩内容~

您需要 登录 才可以下载或查看,没有帐号?立即注册 新浪微博登陆

x
如题
安装了ncl 6.4版本,整个WRF WPS的过程都没有出现error, 但成功安装完wps,发现缺少那两个.exe,有人知道如何解决吗?多谢

本帖被以下淘专辑推荐:

密码修改失败请联系微信:mofangbao

新浪微博达人勋

发表于 2017-8-25 23:51:27 | 显示全部楼层
本帖最后由 packard 于 2017-8-25 23:56 编辑

所以原来wps默认是不会compile plotgrids 和 plotfmt 的?
在我的3.8.1版本里, WPS/compile 能看到这些行:
  1. if      ( ${#argv} == 0 ) then
  2.     set names   =   ( geogrid ungrib metgrid g1print g2print   rd_intermediate mod_levs avg_tsfc calc_ecmwf_p height_ukmo int2nc )
  3.     set NAMES   =   ( GEOGRID UNGRIB METGRID GRIBUTIL GRIBUTIL UTIL            UTIL     UTIL     UTIL         UTIL        UTIL   )
  4. ...
  5. else if ( $1 == plotfmt ) then
  6.     set names   =   ( plotfmt )
  7.     set NAMES   =   ( UTIL )
  8. ...
  9. else if ( $1 == plotgrids ) then
  10.     set names   =   ( plotgrids )
  11.     set NAMES   =   ( UTIL )
复制代码
如果编译时执行 ./compile ,那就是走if的第一行,里面没有plotfmt 和plotgrids。
试试走 ./compile plotfmt 以及 ./compile plotgrids 来指定编译他们。
看看能不能编译,以及有没有报错信息。

ps. 我跑wrf也是有些年了,从来没用过plotfmt和plotgrids.exe。他们不是必须的。plotgrid可以直接用plotgrids_new.ncl那个脚本来替代。plotfmt是用来查看intermediate file的,但一般没什么bug我就直接生成metgrid以后再查看有没有错。
密码修改失败请联系微信:mofangbao
回复 支持 2 反对 0

使用道具 举报

新浪微博达人勋

 楼主| 发表于 2017-8-25 20:08:14 | 显示全部楼层
另外,为了尝试添加这两个程序,我单独把WPS重新configure和compile了一遍,那之前在WPS后装的grads, ARWpost会有影响吗?
密码修改失败请联系微信:mofangbao

新浪微博达人勋

发表于 2017-8-25 20:34:31 | 显示全部楼层
这两个程序和ncl的库有关,但这两个程序有什么用吗?我反正没用过
密码修改失败请联系微信:mofangbao

新浪微博达人勋

 楼主| 发表于 2017-8-25 20:52:43 | 显示全部楼层
说明里,说是可以生成图像的,不需要吗?This utility produces contour plots of the fields found in an intermediateformat
file. If the NCAR Graphics libraries are properly installed, the plotfmt program is
automatically compiled, along with other utility programs, when WPS is built.
密码修改失败请联系微信:mofangbao

新浪微博达人勋

 楼主| 发表于 2017-8-27 14:21:13 | 显示全部楼层
本帖最后由 dolphinmaz 于 2017-8-27 14:23 编辑
packard 发表于 2017-8-25 23:51
所以原来wps默认是不会compile plotgrids 和 plotfmt 的?
在我的3.8.1版本里, WPS/compile 能看到这些行 ...

谢谢 我在我的文件里找过,根本搜不到plotgrids.exe & plotfmt.exe的文字 从你多年经验看 看来真不需要 只是好奇为什么manual里有
密码修改失败请联系微信:mofangbao

新浪微博达人勋

发表于 2019-12-27 11:02:01 | 显示全部楼层
packard 发表于 2017-8-25 23:51
所以原来wps默认是不会compile plotgrids 和 plotfmt 的?
在我的3.8.1版本里, WPS/compile 能看到这些行 ...

感谢,实用出真知,不再纠结于这俩exe的生成问题了~
密码修改失败请联系微信:mofangbao
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册 新浪微博登陆

本版积分规则

Copyright ©2011-2014 bbs.06climate.com All Rights Reserved.  Powered by Discuz! (京ICP-10201084)

本站信息均由会员发表,不代表气象家园立场,禁止在本站发表与国家法律相抵触言论

快速回复 返回顶部 返回列表