立即注册 登录
气象家园 返回首页

Lighting的个人空间 http://bbs.06climate.com/?55384 [收藏] [复制] [分享] [RSS]

日志

opensuse42.1 使用 pip 安装库问题

已有 278 次阅读2016-2-27 20:43

             使用pip 安装python库时如果出现下列错误:
             error: command 'gcc' failed with exit status 1
             先查看有没有安装python-dev(python2.x版本),如果使用的是python3.x版本查看是否安装python3-devel。如果已安装,但是还是不行,需要查看是否安装libevent-dev,如果没有安装,安装好之后即可。
==========================================================
       以上信息仅适用于缺少python-devel或是python3-devel的情况,并不适用于大多数情况。解决此类问题主要还是学会看错误信息,经过几次的摸索发现了其中的门道,但是均忘记截图,以后再遇到类似情况当截图记录。

评论 (0 个评论)

facelist doodle 涂鸦板

您需要登录后才可以评论 登录 | 立即注册

Copyright ©2011-2014 bbs.06climate.com All Rights Reserved.  Powered by Discuz! (京ICP-10201084)

本站信息均由会员发表,不代表气象家园立场,禁止在本站发表与国家法律相抵触言论

返回顶部