请选择 进入手机版 | 继续访问电脑版
爱气象,爱气象家园! 

气象家园

 找回密码
 立即注册

QQ登录

只需一步,快速开始

新浪微博登陆

只需一步, 快速开始

搜索
查看: 1999|回复: 1

[MeteoExplorer主题] MeteoExplorer 1.3在Ubuntu 14.04 LTS上启动失败的问题

[复制链接]

新浪微博达人勋

发表于 2014-6-18 06:42:19 | 显示全部楼层 |阅读模式

登录后查看更多精彩内容~

您需要 登录 才可以下载或查看,没有帐号?立即注册 新浪微博登陆

x

问题描述:在Ubuntu 12.04/14.04LTS上运行MeteoExplorer 1.3.235,会出现如下错误:

./mexplorerbin: error while loading sharedlibraries: libjpeg.so.62: cannot open shared object file: No such file ordirectory


解决方法:上面出错消息的意思是在Ubuntu系统中找不到libgjpeg.so.62这个文件。原因是MeteoExplorerLinux版本是在一台CentOS Linux机器上编译的,而CentOSUbuntu使用的JPEG库文件版本号不一致。解决方法是在Ubuntu系统中找到JPEG库文件的位置,然后创建该库文件的符号链接到libgjpeg.so.62。具体的命令如下:

$ locate libjpeg

/usr/lib/x86_64-linux-gnu/libjpeg.so.8

/usr/lib/x86_64-linux-gnu/libjpeg.so.8.0.2

$ cd /usr/lib/x86_64-linux-gnu

$ sudo ln –s libjpeg.so.8.0.2 libjpeg.so.62
创建完符号链接后,再次启动MeteoExplorer,应该可以成功运行了。
密码修改失败请联系微信:mofangbao

新浪微博达人勋

发表于 2014-6-26 15:17:36 | 显示全部楼层
看看怎么样!!!!!!!!!!
密码修改失败请联系微信:mofangbao
您需要登录后才可以回帖 登录 | 立即注册 新浪微博登陆

本版积分规则

Copyright ©2011-2014 bbs.06climate.com All Rights Reserved.  Powered by Discuz! (京ICP-10201084)

本站信息均由会员发表,不代表气象家园立场,禁止在本站发表与国家法律相抵触言论

快速回复 返回顶部 返回列表